PDA

View Full Version : Picnic Escape 2



Carts
11-03-2009, 17:01:25
It's a friday and it's the best time to escape the picnic! Good luck!

Play here (http://www.stoneagegames.com/games/1652/picnic-escape-2)

Please use spoilers to give hints:
Enter text here...

RBS
11-03-2009, 17:12:35
Well I am taking the potato salad...off to play.

Yikes, stuck very quickly. Got this so far

shovel (used once with luck), fishing pole (used), saw (used), a wooden cross (used), key and I think a remote

slerk
11-03-2009, 17:27:32
Out! It has a weird ending...but, of course, it's a SAG.

RBS
11-03-2009, 17:32:52
Good job slerk. I must be missing out finding a screen. I can't find any use for my inventory.


Edit: Oh, I am out. That was an odd finish.

slerk
11-03-2009, 17:37:18
The way I got out, which is the weird (and SAG-like part) is:

First I tried combining the key and the remote which, of course, doesn't work. Then I was just clicking around the upper right part of the screen, looking for another view or something to use the key and remote on when, poof!, I escaped successfully. I don't know HOW that happened

Ah, I see RBS concurs.

donaud
11-03-2009, 17:53:08
combiningremote w/ key worked for me (not the other way around).

and since when doesputting wood in a depression in the ground yield a key !!??

RBS
11-03-2009, 17:54:26
I can't really complain. I was trying to saw flowers out of the ground.

Anything goes.

slerk
11-03-2009, 17:56:30
I can't really complain. I was trying to saw flowers out of the ground.

Anything goes.

You too?

RBS
11-03-2009, 17:57:53
Yep, neighbor borrowed my pruning shears.

butterphish
11-03-2009, 20:05:04
really weird n short also got out on accident:unknw:

SueJ999
11-03-2009, 21:50:57
I got a shovel... having strange zooming experiences (click on one thing and zoom in on something totally different!

Woohoo, got a fishing pole and fished for a remote(?) but that's it so far...

Finally found the saw but had to use their walkthrough to find something to saw (Yes, I tried flowers and rocks and benches!) The end was really combining the key & remote thing!

Ending made no sense, and I have a cramp in my hand from clicking so much!

old biker
11-03-2009, 22:19:02
if this was for real ,they would have a lot of firewood

minimaker
11-03-2009, 22:23:34
A bit odd but OK.

old biker
11-03-2009, 22:31:07
yeah..right...im finally out ,but ...

NannaJoy
11-04-2009, 02:44:42
I found wooden cross but can't dig it up or saw it down which evidently is needed. ARGH
looked for other likely places to use tool but nothing .. exiting - maybe try again later.

DONK2DONK
11-04-2009, 03:27:03
Ok so here the full walkthrough if you need it -
this ones more a case of finding where to click


1- go left - jokes
2 - click the center of the blue shed thing - get a shovel
3-click the christmas tree to the right of that -use shovel - get fishing rod
4-go to pond in center - use fishing rod - get phone?
5-click bench at top - kind of hiding behind yor shovel in ur items list -on bench get saw
6-see the rocks - by the red shed thing - click that area
7- use the saw on the fence (left) get x piece
8-now for the other hard to find place
9- click in the center of the screen jst above the pond -
10-place the x where it should go
11 - get keys =
12 - combine keys and phone?
13- yay? Lol

mixebouquet
11-04-2009, 05:13:10
weird...didn't make much sense :s