PDA

View Full Version : Gazzyboy Everest Escape



Mistery
02-22-2010, 18:47:43
Gazzyboy Everest Escape is another room escape game from Gazzyboy.
Good luck!

Play Here (http://www.gazzyboy.com/gamedisp/420/everestescape.htm)

Please use spoilers to give hints:
Enter text here...

Please do not post a video walkthrough for 7 days.

Yvonne
02-23-2010, 11:42:08
Okay, lets see if i can do this one without help.
Here goes....

Edit: me being blond again. Stuck after 4 min. And no one arround to ask for help. Have found 3 pieces of wood, piton, ice berg but no clue on what to do with it. Cann't enter cave because of low bodytemp.Will check with EG24 but get there most of the time way more help than I want. I probably want to do these escapes faster than I should.

After a peek I found out that I was using the wrong tool at the right place. use iceberg on iceberg near bag that's in the wall
Got a lot more stuff but still cann't go ahead.

Rexroth
02-23-2010, 12:16:48
Hi Yvonne
Maybe I can help - working from home today but a little playing is allowed isn't it?
Try putting some of the gear on the body to increase temp.
Then you can enter cave :)
Used ice axe to unblock end of tunnel

Jucus
02-23-2010, 12:21:17
Use axe to open bag, put some things on to make your temp higher, but now im stuck. Cant go out, cause its too dark in the cave.

Okay, i managed to go further
To put on things you have to put the things on the human form which shows you your temp.

Yvonne
02-23-2010, 12:30:00
Hi, yes found out that I already could enter cave but hadn't tried it anymore. Was looking for matches but haven't found any.
Am in cave now and build a thing and now stuck again.
Found more clothes but I don't want to wear them.
Glad someone has come to my rescue. Felt kinda alone out here.

Edit:
My inventory says I have a lot more stuff than I have. Know what to look for, now only have to find out where that stuff is.

Jucus
02-23-2010, 12:32:26
You actually buld something? I cant XD
Got another bag with lots of stuff btw. Cant wear other clothes now from the 2nd bag.

Yvonne
02-23-2010, 12:36:03
Jucus, use leg wear in the middle with the wood and the plate from the second bag.
After that i'm stuck

Don't know why the thing is called a leg wear. I have other ideas about leg wear but that is what the inventory says.

Bodytemp is dropping again so cann't go in other cave. Need to heat up first.

Got the iceberg from inventory on the plate. Don't know how because i was messing with the 2nd bag. And now what?? So stuck

Jucus
02-23-2010, 12:41:36
Hehe yes i see, thanks.
I put iceberg in the plate.
use that red stick in the little hole at the bottom of the legwear

EDIT: Brb, lunch time :D

Yvonne
02-23-2010, 12:43:56
Right there with you. Have bottle filled with hot water and glucose but body doesn't want it.

Okay, I'm going to eat something too. See you later.
Bon Apetit, or something like that.

Rexroth
02-23-2010, 12:47:18
Um - I got the cooker going after getting sll the new stuff in new room. Used it together with string (placed in middle), sticks (placed in holes around outside), placed plate and ice on top of sticks then used what was called 'bottle of warm water' to start the whole thing... added glucose and put it in bottle.
But cant get body to take it..
EDIT - same here Yvonne maybe it needed to cool down?
Warm and in next tunnel

Yvonne
02-23-2010, 12:50:55
I think the inventory has a nervous breakdown because the words that goes with the items don't make sence.

I'm there where you are. Tried melting things with my hot water but it doesn't work.

Edit:
Tried it again and body took the bottle so now it's warm again and I can continue.

Entered cave and found a lot of stuff. Cann't get the rope or the shoe with iceaxe so need to find something else. Bodytemp is down so need to warm up again.


Found another iceberg to use for shoe and rope. Cann't find another cave to enter and bodytemp is still down.
Don't know what to do with the things I found.

Jucus
02-23-2010, 13:10:49
I cant knock off the 2nd iceberg with axe :(
I think most of the new things will need at the end, like climbing down from the mountin, i guess.

Rexroth
02-23-2010, 13:13:16
Yvonne - where is the rope?
EDIT: found it (in middle of screen)
Anyone found out where we can go with all the gear?
Temp is falling!!!
EDIT: OUT!
Hit pitons in ice wall (middle of screen) then added rope.
Used climbing pick to dig hole the LOL added gas bottle which shot rope up in air!!!
Now you can use all of the new equipment on the body before you leave.

Yvonne
02-23-2010, 13:16:14
at the bottom of your screen you see icebergs. You can pick up the 3rd one on your right, I think

Used iceberg on a big iceberg and now it is gone. Don't know if I found something. Inventory makes no sence. Items have strange words. Cann't make head nor tails of it

Edit: Rexroth i think we are stuck.
Cann't find an exit and have no clue about what to do next.
Am running arround in circles. Cann't go back to first cave to see if i missed anything or to see if there is a climbing way out there.
Had when i got back my iceberg back in inventory and used it again and now it is gone again. I'm freezing out there.

Jucus
02-23-2010, 13:24:21
Thanks Yvonne. Got the things. I cant use the iceberg on a bigger one. Theres one on the left of the screen but it didnt do anything.
BUT try clicking on the top middle of the screen.

Yvonne
02-23-2010, 13:27:47
Good job Jucus, found what you meant. Now i have to figure out what to do there.
Cann't seem to break anything and nothing from my inventory is working on that spot. I'm missing something but cann't figure out what.

Jucus
02-23-2010, 13:37:40
Still cant hit the big iceberg with 2nd iceberg.

Yvonne i think you have to find some spots where you can use those sticks. Theres another "screen" under the "top screen" too.

Yvonne
02-23-2010, 13:41:08
Stop searching the big iceberg, i think it's a bug. I find out that I could keep hitting spots that we already had, the one with the rope and with the shoe. It wasn't doing anything, I wasn't getting anything.

Will try to use the pitons but have already tried it. Must find the right spot.

Edit:
Jucus, do you mean the seen where we found the rope or do i have to find another seen?

Edit: Never mind i think i found it. Now what to do with sticks, they don't want to stay on my screen in an iceberg or something.

Jucus
02-23-2010, 13:43:53
Gosh, you're right... I hate buuuuug :sad:

EDIT: Its a bit under the TOP scene. It doesnt work sometime, cause of some bug i guess...
BTW i cant use the pitons there...

EDIT2: i'll restart the game, maybe better luck next time :D

Yvonne
02-23-2010, 13:51:40
What stick are you talking about then.
I don't think I have sticks.
Will check inventory, maybe will find something that is called sticks but is in fact something else.
Inventory is bugged.

Jucus
02-23-2010, 13:55:10
I ment the pitons or what their names are. :D
Okay, i really think it doesn't work cause the inventory is bugged.

Yvonne
02-23-2010, 14:02:06
Jucus, i'm out.
We should have read the message of Rexroth #13. He has been out for ages.
Use the pitons not zoomed in.
First all the pitons and then axe. Do what Rexroth said and you will be out.
Thanks for the help.
See you arround.

Edit: Will check later to see if you got out as well. So please leave a message.
Good luck

Jucus
02-23-2010, 14:05:50
Lol, i just wanted to write the same before i refreshed the page ! XD Im OUT too :D
Thanks for all your help :)

BchBum
02-24-2010, 03:01:15
out with Happy Sherpa ending-:D



- thanx for the help everyone-

blueangel319913
02-25-2010, 03:03:32
I'm stuck