View Full Version : Abandoned 2

03-17-2010, 19:59:44
Abandoned 2 is the sequel to Abandoned 1 from Melting-Mindz. After the last paranormal investigation you told yourself you wouldn’t go on another one. That was over 2 years ago. Deciding to take on Black Ridge Manor alone might not be the greatest idea but facing your fears is said to be the best way to conquer them.

The game is not suitable for children.


Please use spoilers to give hints:
Enter text here...

Please do not post a video walkthrough for 7 days.

03-17-2010, 21:44:31
I have only found shovel and wood peg so far :S

03-17-2010, 21:47:19
i'm right with you, mistery. i've been walking back and forth through the 3 screens i can get to..... and can't find anything else other than a barred window :'(

EDIT: scratch that, i just found something if you click around the left side of the path with the shovel you can find a key.. i don't know exactly where because i was just clicking randomly with it

03-17-2010, 21:48:21
Phew, thanks, now I'm feeling less dumb :haha:
Okay, let's hope that someone else finds the next step.

03-17-2010, 21:48:36
Hi Mistery I'm glad you're here. Good game so far but hard.

You need to find 3 pegs.

Hi Krisdone.

Use the shovel on pile of dirt to ge inside

03-17-2010, 21:50:40
Hi dalveen! :D

Mistery, i just edited my previous post... see above ;)

03-17-2010, 21:52:46
I've just already found the key.
But no other pegs, is it such a pixel hunterish game? :(

Hmmm, the quality of this game seems to be rather bad compared to the Flophone series and other Melting Mindz games :hmm:

03-17-2010, 21:57:18
Sorry Mistery I think I have confused you the other pegs are inside.

I am completely stuck. I think I might wait on you guys.

03-17-2010, 22:01:17
looks like i'm stuck now too.. i have the three pegs, a chisel, and an old sponge

did you find anything else dalveen?

03-17-2010, 22:04:04
Use sponge on wall behind kitchen utensils

03-17-2010, 22:05:45
nice one!

ooooooh... i found where the pegs go :smile:

03-17-2010, 22:06:20
It took me at least 10 minutes before I realized that the "move forward hand" appeared on the very top of the screen. :P I'm not too fond of the navigation but I am in the house and exploring.

03-17-2010, 22:06:37
The 3 pegs fit into holes on a object that looks like a table. It's in a room by itself

In the room wher you found chisel wipe the wall

I also found bolt cutters - but I can't remember where.

03-17-2010, 22:12:23
the bolt cutters are from the place where the pegs go

03-17-2010, 22:16:47
Use them on chain to get ladder and go across hole to other room

I have just found a key and fish??

03-17-2010, 22:19:22
I only found spade (used), key (used) 2 pegs (used), chisel (used once), and a sponge (used).

So I'm left with the chisel only.

Can't find the third peg or the bolt cutters.

edit: found the third peg at last

on top left of the entrance door.
when entering the house go straight ahead and move the poster on the right of the door opening.
when entering the house go left and use chisel to break the glass of the window.

And got the cutter
out the tree pegs in the holes of the table in the room mentioned before in this thread

03-17-2010, 22:24:54
dalveen... where did you find the key??

03-17-2010, 22:28:30
Once you go across ladder into other room use the chisel on the green tiles. I am still trying to find more fish (found 2 so far)

Found 4 fish same colour as spots but I don't know what to do with them and I still haven't found where the key fits.

03-17-2010, 22:37:39
Go back to hall you after entering the house. Go right, go backward. Use the old key on the locked door.

Can't find any of the fish.
are they all behind the green tiles?

Edit: Found first fish (the red one). and the blue one

the fish combined with the colored circles are..
the clue to open the desk's drawer in the new room.

Still two fish to find..

edit: found all fish and opened drawer to get a book.

03-17-2010, 22:39:37
I can't get my key to work where you say Adventure. Ignore me I am such a fool. I didn't click after using key.

Behind tiles same as key

That's me just found the key for the panel. Now trying to work out lightsturn them all to red

Has anyone worked out the piano?

03-17-2010, 22:44:27
Thanks Dalveen. :)

Updated my previous post btw.

edit: found security key
in the book

used security key
on panel next to the phone. Switch the switches to make all the lamps red, and it opens the door.

edit: found..
matches, key and amulet piece.

Alice carved on the hospital bed.
On the right of the piano keyboard is written something like: doe e doe??
Tried playing "dce e dce" but that didn't accomplish anything.

Used new key to unlock the other door
main hall, left, left.

Used matches
to lit the 2 candles and got another piece of the amulet.

Placed the 2 amulet pieces
on the silver disk.

03-17-2010, 22:55:45
i'm exactly where you are, adventure. i can't think of anything else to do except to fiddle with the piano... i don't have any sound on though - is there something i need to be listening for at the piano?

03-17-2010, 22:59:34
All piano keys sound the same. I guess we have to tune it first.

edit: The answer is no
check the book again. ;)

Got third piece of amulet. Now where can the last one be. :hmm:

03-17-2010, 23:01:44
ahh... okay.

i have 3 amulet pieces now :D

03-17-2010, 23:05:14
Me too. ;)

I wonder if we have to use the telephone list somehow someswhere to get the last piece.

edit: Found last piece! :D
Use the chisel on the electricity closet in the room with the hospital bed

Out! Nice game. I enjoyed it. :)

03-17-2010, 23:09:25
Where are the pegs? I been looking for ever....going in cirlces

EDIT: Found 1

03-17-2010, 23:11:22
Where are the pegs? I been looking for ever....going in cirlces

EDIT: Found 1

I made a spoiler for the pegs in this post

03-17-2010, 23:12:26
I made a spoiler for the pegs in this post

Thanks! :D

03-17-2010, 23:15:25
Happy I could help. :)

Wow 49th on the score board because of the 11.090 clicks I made. :laughSMILE: I am sure at least 6000 clicks are for figuring out the navigation system. :P

03-17-2010, 23:21:15
hmm... i already have that amulet piece... which one am i missing? i have the ones from by the hospital bed, the candles, and the box with the code.......

03-17-2010, 23:25:06
Did you play the piano?

03-17-2010, 23:26:07
@Krisdone, You are missing the one..
from the piano. Check the spoiler in post #23. :)

I thought that was the third piece you found.

03-17-2010, 23:30:06
D'OH! thanks guys! :smile:

EDIT: hahahaha.......... 17,725 clicks!!!

03-18-2010, 00:06:31
16,800 clicks... *whew*.

Nice game. The pegs, navigation and the tiles were the click-hogs for sure :D

03-18-2010, 01:29:10
After 16,593 clicks, I am out. I took a couple of early nudges, TY krisdone and Adventure. Good game:)

01-02-2011, 19:19:04
21281 clicks but I finally made it out.
Thanks for the help
On to the third one in this series of very good games