PDA

View Full Version : Amberdale



Ronsoca
12-03-2010, 14:43:06
Amberdale is a new room escape game created by Selfdefiant for CafeCafeGames. You have awoken to find yourself in a strange place. Moment later you realize that you have no idea who you are, why you are here or where here is. All that you know is you must escape!

Play Amberdale (http://www.cafecafegames.com/games/3031/amberdale.html)




http://4.bp.blogspot.com/_Gn-53BPEQhs/TPjvEdtwT6I/AAAAAAAAJRw/zFD5DTr5Ycs/s400/amberdale-150x120.jpg

Mistery
12-03-2010, 15:07:23
Got
key (used), matches (used but still in inventory), map, screwdriver, green and blue heart gem.

Found black key and axe. Seen a wooden board with shapes :hmm:
Also found a metal board with switches to turn, no clue found yet how to solve it.

Found yellow gem and purple gem.

Scissors
12-03-2010, 15:12:22
This epsode is much more difficult for me than the last. So far 4 gems, black and silver keys (used), SD (used, still there), axe, matches (used)
Need the red and green keys.

Mistery
12-03-2010, 15:15:14
It appears that we're at the same place.

Have you found clues for board with shapes, and for metal plate with switches to turn?

Scissors
12-03-2010, 15:16:20
It appears that we're at the same place.

Have you found clues for board with shapes, and for metal plate with switches to turn?

Nope, still looking, Mistery.

EDIT: found fish-shaped clue in room with 4-digit box, level 2, far right room
Red key! use fish shapes on metal plate

Mistery
12-03-2010, 15:23:09
Yup, I've got that, too.
Got red key.
Found red gem. And now also green key.

Found place to put gems, but don't know order :hmm:
Oh, and I'm missing 1 gem.

Scissors
12-03-2010, 15:28:12
Right with you. Looking for clues for the wooden board/shapes.

Was there anything in the room with the adjustable bed??

Mistery
12-03-2010, 15:32:43
Or it might be a clue for a puzzle. Anyhow, haven't found anything related to it :hmm:

tipper75
12-03-2010, 15:33:51
Getting along well.in a crack in the "bead" room, can't get it

Too bad, I have to go to work before I finish:(

Mistery
12-03-2010, 15:35:37
@Tipper
You need screwdriver

Awww, I hope you can finish it after work :hug2:

EDIT
@Scissors
No, there was nothing in that room, I found that strange, too.

Went through all rooms again, but nothing :S

tipper75
12-03-2010, 15:37:39
Bye, SD did not work:?

Edit: ax worksbut if you use it in the last room, you lose it:?

Scissors
12-03-2010, 15:43:18
Any luck, Mistery?

OUT! (With help from selfdefiant)
click the shapes in order of number of sides (which I tried many times), BUT DON'T click the heart shaped one.

This makes sense to me now (hits self in forehead with heel of hand)!

Mistery
12-03-2010, 15:46:11
Nope, still looking and mousing slowly around to find a hotspot :haha:

EDIT: Oh my, I think I'll be stuck forever in this house, I wanna get out! :P

Duh, I tried that so many times like you - clicking all. :P

Out, too, thanks :D

NannaJoy
12-03-2010, 17:07:23
good morning. found 2 items, one used, and noted two clues. So I'm off like a herd of turtles.
9 rooms in and out of, opened one code box. Need a light and something to stick in a crack. So moving along and not pulling out my hair yet.

BchBum
12-03-2010, 17:25:24
OUT... was going smoothly until the symbols...

you have to click under the symbols and not the symbols itself

NannaJoy
12-03-2010, 18:19:15
My map odd - next to last row and I head north, I seem to go cross-wise rather than due north. Missing two hearts. Also one heart is different color than what they tell me.
have sd, map, matches and 5th heart. Have something in a crack to deal with. Need to find a new tool or ?

kirahvi
12-03-2010, 18:51:43
NannaJoy, you need an axe. It was on a table in some room, can't remember in which, sorry.

I'm stuck with the color order. Any help?

Edit: POP I had forgotten about the colors in the shapes puzzle.

NannaJoy
12-03-2010, 19:09:10
I used that item elsewhere and no longer in my item list. Someone else said an item I have but that isn't working. Could I have left it on the floor? LOL
Maybe I'll restart ..
I did and your idea did work and I got back item to use again. Thanks
and out - 339 clicks

Yvonne
12-04-2010, 16:34:17
This looks like it is my day to get stuck again.
Haven't found the SD and I have searched everywhere.
Can't move on without the SD
Looks like it is also my POP day.
Got SD now.
Out with 543 clicks

La Senza
12-04-2010, 16:59:56
Can anyone tell me where they found the red gem PLEASE!! S'ok found it after a manic clicking spree!!!

celiax2516
12-06-2010, 17:25:43
And 999 clicks!