PDA

View Full Version : Escape From Island



Mistery
07-28-2007, 13:44:04
Another game by the creator of Jinja in English. Your plane has crashed on an island, and you need to escape by collecting items, and using them at the correct place. Good luck :)

Play Here (http://aztec.sakura.ne.jp/escapefromisland/index.html)

Please use spoilers to give hints:
Enter text here...

Walkthrough (http://gamershood.com/forum/showpost.php?p=438861&postcount=44)



3715

Jeral
07-28-2007, 13:52:27
Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Apache/1.3.37 Server at aztec.sakura.ne.jp Port 80

=(

Mistery
07-28-2007, 14:00:07
I had that, too first. But it's working for me currenty. :)
Could be that the server is busy?
I hope that you can play it soon, too :)

So far I got:
rope (used), tank (used), arch & arrow (used), pick (used once), lighter (used 3 times)
not used yet: shovel, saw, knife, fishline and hook (can't combine :S)
Still room for 8 items in my inventory.

And I seem to be stuck...

EDIT: used saw and got
log
Stuck again. And I still don't get how to combine objects. Tried to drag them over each other, and also the zooming tool...

Lilliputt
07-28-2007, 14:51:39
BOAAAH! :'( Not workin' for me either :sad: It looks like a fun game.... http://www.gamershood.com/forum/images/icons/icon11.gif

EDIT: HEY! It's workin' :o Thaz weird :? Oh well... hurrah! :leb:

Mistery
07-28-2007, 14:54:10
It seems that in order to keep the game working for those who have started, the number of players who get access might be limited at the moment.
Or the server is too busy, and you need to try a couple of times until the game loads.

Adventure
07-28-2007, 14:57:26
So far I have found:
shovel, saw (used), rope (used), knife, fishline, key of stone, jerry can, pickaxe (used once), bow with arrow(used without effect, gladly), bamboo branch, trunk. Further I found a message: watch out for purple and a locked door.

Seems I am way behind you, Mistery.

Mistery
07-28-2007, 15:01:17
Adventure, you can drag the items onto the check button to see what they are. ;) The yoyo is a fishline :)

Arch & arrow:
use them in front of you at the location where you have attached the rope, you'll get a bridge

Is the muddy key that you mention the "key of stone"?

Adventure
07-28-2007, 15:05:43
Adventure, you can drag the items onto the check button to see what they are. ;) The yoyo is a fishline :)
I just found that out too. I edited my post. ;)


Arch & arrow:
use them in front of you at the location where you have attached the rope, you'll get a bridge
Thank you. :D Gonna try that out immediately. ;)


Is the muddy key that you mention the "key of stone"?

Yes, it is. :)

Mistery
07-28-2007, 15:07:25
Yay, combined 3 items :D
bamboo rod, fishline, and fishhook

And got fish :)

Used fish
gave it to animal in cave

Used key of stone.
Got key of ruby

Used lighter again.

Found purple thing ;)

Adventure
07-28-2007, 15:11:30
And I made some progress :
Used bow and arrow, found hook, filled jerry can with water and used it, found lighter as well. :D I am still trying to combine the bamboo branche, fishline and hook... EDIT: Succeeded!! ..And cought fish too.:D

Mistery
07-28-2007, 15:14:18
Got golden staff.

Used knife
to cut off animal at waterfall
Got key of diamond

Lilliputt
07-28-2007, 15:14:25
Oh, how nice. I got a
key of diamond :)

Mistery
07-28-2007, 15:20:48
Used golden staff
on the square stone with hole
Used then shovel to get purple crystal ball

Adventure
07-28-2007, 15:21:14
More progress:
Used fish and key, found purple key and used it, found golden staff.
Lol, I am still behind all of you. :P

Mistery
07-28-2007, 15:22:22
Yaaaay, I'm out!!!!
Wow, what a phantastic game!!!! :D

Lilliputt
07-28-2007, 15:22:37
FINISHED!! :leb:
That last part was very funny :haha: Whaz ya think, dear da alien? ;)

Hayles
07-28-2007, 15:23:34
in my inventory i have lighter not used, saw not used, purple eye not used, pick axe used once and diamond key not used
any help?

Mistery
07-28-2007, 15:26:28
Saw
Use it on tree above cat

Lighter
Use on the 4 statues

Hayles
07-28-2007, 15:29:03
yea thank you Mistery got out really nice game!!

Adventure
07-28-2007, 15:29:08
Yeah, I am out too. :leb: Great game!! :D

rehtse
07-28-2007, 17:30:00
Anyone there???I can't find the lighter:(

Mistery
07-28-2007, 17:33:55
As far as I remember, the lighter
is in the burning plane. You need to get water first and put out the fire

ShiningStar
07-28-2007, 17:35:25
I can't seem to get the water

rehtse
07-28-2007, 17:36:54
Thanks Mistery!!!Nice new avatar:)

Mistery
07-28-2007, 17:38:25
@*~shiningstar~*
Do you got the tank?

To get water:
You need to use rope and go down to get arch. Then use it when you go up on the bridge in front of you. Find the waterfall

Thank you rehtse :)

rehtse
07-28-2007, 17:39:44
FINNISHED!!!!!
That's a good game !!!!:D

ShiningStar
07-28-2007, 17:41:06
found the tank and where the waterfall is but when I try to get water it doesn't get any!

Mistery
07-28-2007, 17:42:02
Just drag the tank onto the water

ShiningStar
07-28-2007, 17:57:19
finaly got it to get water, thank you!

jenni.p123
07-28-2007, 19:24:37
where do i use the "rod" to get the fish :?

Lilliputt
07-28-2007, 19:29:19
You gotta get
the bridge down first ;)

jenni.p123
07-28-2007, 19:31:59
yeah ive done that :D

EDIT got it :D

Lilliputt
07-28-2007, 19:33:02
Good :D You smart :D :D :D

jenni.p123
07-28-2007, 19:39:02
where do i find the golden staff :?

item : lighter (used), shovel, saw (used) , rope (used), knife (used), string (used), hook (used), fish (used), ruby + diamond keys, tank (used), pick (used once) , arrow + bow (used), and log.

crazy mad0
07-28-2007, 19:43:41
Hmm where do i get the saw?

jenni.p123
07-28-2007, 19:45:54
umm..i cant remember :S

crazy mad0
07-28-2007, 19:51:39
lol i have ighter,spade,thingy that looks like its for wallpaper, rope, knife,line hook key tank pickaxe and bow +arrow .... ahhh

mouthybrat
07-28-2007, 19:51:45
Really good game!!! I got through most of it without any help...actually up until the end, I hadn't used the lighter on the four statues!!!

crazy, use the thing that looks like it's for wallpaper on the tree next to the cat

I'll post a walkthrough if anyone wants me to...

Adventure
07-28-2007, 19:52:47
Use ruby key on the keyhole in the cave.

In the first tunnel. It looks more like a gigantic putty knife. You probably have already found it. ;)

When you drag the items to the check box in your inventory, you can observe them more closely and also combine items. :)

crazy mad0
07-28-2007, 19:54:43
oh so i have ...what do i do with the llog nd how do i get bamboo please ?
THANKS ADVENTURE !!! :D

jenni.p123
07-28-2007, 19:55:27
now i only have key of diamond, pick, log, and purple crystal ball.....:hmm:

EDIT i finished!!! :D
:leb:
thanks for everyone's help :)

Adventure
07-28-2007, 20:02:51
@Jenni, did you already used your lighter four times? If yes..
Climb the white trunk by using one of your items. ;)

EDIT:

Congrats Jenni!! :applause:


oh so i have ...what do i do with the llog nd how do i get bamboo please ?
THANKS ADVENTURE !!! :D
You need the log later. ;) And you are welcome. :)

Cross the right bridge on the island to go to the bamboo bush. You find the bamboo twig there.

Iva
07-28-2007, 20:09:13
Yay! Finished! I used some of your spoilers :$
But I didn't use the gold flake
Was that some kind of payment in the end?

mouthybrat
07-28-2007, 20:21:32
Go RIGHT once and UP ONCE, pick up shovel
Go back, then LEFT TWICE, pick up fishing line
Go RIGHT ONCE, and UP ONCE, pick up saw
Go UP ONCE, pick up rope
Go UP ONCE, use saw on tree where cat is lying, get log
Go LEFT ONCE, get pickaxe
Go RIGHT ONCE and UP ONCE, get knife
Go RIGHT ONCE and UP ONCE, get tank and take bamboo rod from tree along path it's the only one with a branch
Go back once, LEFT TWICE, use rope on hook on the ground, climb down rope
pick up key of stone, go RIGHT ONCE and pick up bow and arrow
Go LEFT and climb back up the rope
use bow and arrow on bridge across waterfall
go across the bridge, pick up fish hook
now combine fishing line with bamboo rod, then add the hook to do this, simply take the fishing line and put it over the bamboo rod, then take the hook and put it over the bamboo rod as well now you have a fishing rod!!!
Go RIGHT ONCE, use fishing rod on waterfall to get a fish, also fill up the tank with water
Go back ONCE and UP ONCE, give fish to the bear, now you can enter the cave that the bear was protecting!
Go RIGHT ONCE, use key of stone on the door, go inside get key of ruby
Go BACK ONCE, LEFT ONCE, BACK ONCE and RIGHT ONCE, use knife to cut bear down from tree
Go LEFT ONCE and BACK ONCE, bear is on bridge leaving you a key of diamond, pick it up
Go BACK ONCE, RIGHT ONCE, BACK THREE TIMES, RIGHT ONCE and UP ONCE, use pickaxe on bottom of rock, get a golden flake
Go BACK ONCE and LEFT TWICE, use tank of water on fire in plane, get lighter
Go RIGHT ONCE, use lighter on statue
Go UP TWICE and RIGHT ONCE, use pickaxe on rock twice to open a cave
Go UP ONCE, use key of ruby on locked door, go inside, take golden staff
Go BACK TWICE, LEFT ONCE, use golden staff on the hole in the block on the ground, use shovel where the light shines on the ground, pick up purple crystal ball
Go UP ONCE and LEFT ONCE, use lighter on statue
Go UP THREE TIMES, and RIGHT ONCE, use lighter on statue
Go LEFT ONCE, BACK TWICE and RIGHT TWICE, use lighter on statue, the ground will start shaking
Go LEFT ONCE, use log on giant rock that has moved up out of the ground, go up the log, use purple crystal ball on the hole in the thingy, use key of diamond in the small hole that appears...
and you're out!!!

cocoa100
07-28-2007, 20:21:42
Apparently you don't actually need the gold, I just went through the game for the second time and this time I didn't get the gold. It didn't change the outcome at all.

mouthybrat
07-28-2007, 20:23:21
I didn't have the gold the first time either...not sure what it's used for...

Iva
07-28-2007, 20:34:04
Ah well, loved it nonetheless! :D

Swim Girl
07-28-2007, 20:47:49
that was fun but confusing in parts

sleep1937
07-29-2007, 00:26:40
finally i solved something with no help at all.
cute game.

Minoune8
07-29-2007, 00:59:37
Really great game !! Thanks to the walkthrough lol !!

silverflagon
07-29-2007, 01:48:56
I finished it in just 25 minutes with just one hint, thank you. Neat game.

med_girl
07-29-2007, 03:02:25
Excellent game.

Thanks to all for the hints.

Mouthybrat, good walkthrough.

jaggedsmile
07-29-2007, 03:23:44
23 minutes with no hints. And you even get to see the kitty from Jinja again.

Earlyman
07-29-2007, 03:33:06
Not too bad finished in 15 min with no help

vmklover
07-29-2007, 03:34:05
Nvm! turns out i just forgot some statues. Great game thx for the walkthrough

Purp
07-29-2007, 06:16:04
Thanks, Mouthy Brat. This is a cute game.

mez
07-29-2007, 07:29:47
:smile: woo im out wif out any help :smile:

11mins

memememeandI
07-29-2007, 08:13:44
Creepy ending!

JULESMCT
07-29-2007, 14:17:45
finished. great game :)

birdzofafeatha
07-29-2007, 14:54:41
finished
with one inventory space free
and gold flake
but thats already been discused

Cherrytomato
07-29-2007, 17:19:41
Finished in 6 minuetsReally weired ending though.the golden flake was a red herring though,

When i look up in to the sky I think my self lucky that I have a computer other wise I would die."Land with out computers" :mad:

derek44
07-29-2007, 19:13:25
i am stuck with the brown bear looking thing in cave any help?

Mistery
07-29-2007, 19:14:33
i am stuck with the brown bear looking thing in cave any help?

You need to get
fish, and give it to him

derek44
07-29-2007, 19:29:11
oh ok thanks! dont need any help for now but i might later
EDIT: ok... i noticed the walkthru! if i get stuck i will use it!

Mistery
07-29-2007, 19:37:32
Okay, good luck derek :)

derek44
07-29-2007, 19:45:28
yes! finished with half help from walkthru very hard at end! fun game
PS: the end cutscene is very strange... and random i mean... ALIENS?wierd...

(that alien ship looks kinda like the alien cruiser in halo! any connection??? lol just kidding there obviously wont be)

Vega78
07-29-2007, 22:47:49
Wow, I actually did this without help. :)

Weird ending though, someone has way too much time... or fantasy. ;)

LushLaLa
07-29-2007, 22:48:40
GOT OUT! first time never needed any help:)

only couldnt find the 4th statue but apart from that was easy

derek44
07-29-2007, 23:10:15
hey.... this ust occured to me as i was logging off... remember that note? beware of the purple? was that the purple ship thingy or is there something we missed? is that spaceship thingy the wrong ending? is that like a gameover? im trying to figure another way of finishing! that may also be what the golden flake is for!!! wow i never thought of any of this before!!! this explains alot!!! or maybey my mind just wanders a bit too much.......

Mistery
07-29-2007, 23:18:26
To my knowledge, there is just one ending.

The purple thing
was the object which called the ship

Did it really say "beware"? :hmm:

funiax
07-30-2007, 00:52:15
lol good game.funny ending.didnt use gold flake and i had 1 space with no item lol. also didnt need any help.heheh

mouthybrat
07-30-2007, 01:33:35
Come to think of it..it did say "Watch out for purple"...I wonder if you'd get a different ending if you used the gold flake instead of the purple ball???

nope...can't use the gold flake there...

scambo
07-30-2007, 03:55:37
I thought the same thing Mouthybrat and tried the golden flake first...didn't work. This was a cool game.....

bmatt
07-30-2007, 03:56:01
The empty inventory slot in question is filled by an Emerald Green Snack. It is obtained with the pickaxe in the scene with the plane wreck. If you use the pickaxe on the little round rock area on the cliff (above the stick looking scrap a little more than halfway up) you get the snack. Although I didn't use this item at all to finish the game. This may be another red herring or maybe there is another possible ending.

Michelle
07-30-2007, 16:22:22
Anyone here? I never got a saw, so I can't get a log. I have everything else.

There is no saw anywhere.

Mistery
07-30-2007, 16:25:27
Saw
The saw is in the cave to the right of the crashed plane. 3rd item in your inventory

Michelle
07-30-2007, 16:28:27
Oh for god sake! I never viewed what that thing was. I actually thought it was a flashlight that I never needed. I really feel dumb. Geez.

Finished!

rarita
07-30-2007, 21:57:51
That was a good game :-)))

acemonymaka
07-30-2007, 22:02:52
im about to play it

Kjhoe_8273
07-31-2007, 00:00:18
:ura: ive Done It !!!!!:ura:
:ura: :ura: :ura:

Toobs
07-31-2007, 01:43:33
Hello Im Toobs from Argentina.
I play this game, but I finish the game with one empty slot and 2 items (gold flake and emerald green snack).
Searching in another forum I find an aswer for this.

Wow. I found an alternative ending.
After you put in the orb, return down and pet the cat once and then pull it's tail. It will then wake up, and you can feed it with the emerald snack. Then it goes into the space ship and call for help, and you get rescued by a boat at the place with the bamboos.

But that doesn't seem to work for me

Any idea?

OneBun
07-31-2007, 02:40:30
@ Toobs ~ I attempted that ending. It doesn't work for me either. I think it may just be a joke they made up. ;)

ButterflyB
07-31-2007, 03:52:58
I beat the game, didn't find an alternate ending though.

dave
08-01-2007, 18:21:55
Out in 00:32, no help. Bear was funny.

Rannei
08-02-2007, 16:17:53
Wow! great game! I love it :luv:
I was out in 00:27 :D

dragon king123
08-05-2007, 09:18:03
ive not done aything can u help me

smalltowngal102
08-06-2007, 18:15:01
Where do you go fishing at? And do I need bait or something? I can't find the fish.

NVM I found it...in the waterfall . It took me like 8 times to get it it.

muszelia
08-10-2007, 20:57:51
:ura: :ura: I'm finished... I've done it (almost
:wink:) by myself.

WolfiesHeart
08-31-2007, 06:05:11
It barely kept my interest, all the running around and pointless stuff... really made the game lacking!

nefertiti
08-31-2007, 20:02:50
that was so like the wierdest ending ever:jawdropper: :crazy-smilie: :jawdropper: :crazy-smilie: :crazy-smilie: :crazy-smilie: :jawdropper: :jawdropper: :jawdropper:

DREW187
09-03-2007, 08:12:50
IM TOO (h) 4 THIS GAME




:hi3: :hi3: :hi3:

You Should Not Play ThIS GAME

:umn::iq: :umn: :iq: :umn:

nermlecat
09-04-2007, 08:56:36
I've finally finished this game- been trying for about two weeks!
People seem to have trouble combining things...
All you do is click and drag the first item to the other item...Easy!

Themolestarted
09-04-2007, 09:36:41
Did It Yay me:D

NannaJoy
12-03-2007, 22:42:57
Great fun! Did realize that log I was toting was so loooong. No wonder I'm ready for a nap.
time 1;31
Loved it - except always same view - had to adjust my drawn map twice due to that.

Archontic
01-12-2008, 17:10:23
I was actually expecting to use a boat to get off of the island or something, but the way that we got out is much more.. inventive. Out. Great game. Took me 30 min flat.

old biker
05-05-2009, 22:28:58
what a great game !! loved it

Mistery
05-05-2009, 22:44:34
I agree, the series by Aztec Games is one of my favorites. :D
I even emailed them when there was no new game for a long time, to ask them if there are going to be new games. They replied me very fast, I really appreciated that :)

RBS
05-06-2009, 01:15:35
Have not played this in over a year. Enjoyed it all over again. Have the same questions already posted and a couple more.

1. Gold flake and emerald snack not used.
2. Cat doesn't do anything but mew.
3. There is a scene you can get from where you find the bamboo rod showing a tiny peninsula that had nothing to offer.
4. Still wonder if there is an alternate ending some people mentioned. So far it seems nobody has found one.

Great game

flagalstan
05-06-2009, 01:41:49
Havnt played in a year either. Cat won let me shoot it D;

Nanner
05-06-2009, 08:51:40
I remember this game also. Love it. Never found emerald snack mentioned and I didn't use gold flake either.

donaud
05-06-2009, 09:42:15
Very good game.

@ Mistery: Well ??? :)

"I even emailed them when there was no new game for a long time, to ask them if there are going to be new games. They replied me very fast, I really appreciated that."