PDA

View Full Version : True Love 2



Lilliputt
01-28-2008, 17:31:52
This point and click adventure game is a sequel to the True Love game sponsored by Lacta. You do not need to admit an email address, you can play the game as a guest. Just choose the guest option and then "next" at the bottom right corner of the game screen.
You can interact with other characters, pick up items and examine them by scrolling the cursor over the items in the bag, drag and use items. Search for clues and items to help finish the game. Good luck and have fun! :D

Play the game
Here (http://www.emphaze.com/www.truelove.gr/theGameE2Eng.html)

Please use spoilers to give hints:
Enter spoiler text here

EDIT: This game has a limitation. If you play as a guest you will only be able to play the first part. To play the remaining part of the game you have to give an email address, a character name, the name of the true love, a country, and gender. The rest of it can be filled with "x". Make sure to unsubscribe the newsletter at the bottom if you do not wish to have it.

Hayles
01-28-2008, 23:20:02
could only get as far as getting on the plane then they ask you to register was a good game up till then but i hate registering for things

Lilliputt
01-28-2008, 23:27:58
Aww... I didn't play the game through. I'm sorry Hayles :S

Blondiej1
01-29-2008, 00:23:07
i am trying to make fire but i can't light anything help!

Edit: I got the fire started now what i've tried everything in my invintory ? what goes in the middle?!

Lilliputt
01-29-2008, 00:45:29
Well
you need to find 2 diamonds. One goes in the middle :)

I am stuck inside the sphinx with the tablet thingy :P

Blondiej1
01-29-2008, 00:57:57
any hints on to where they are????

Lilliputt
01-29-2008, 01:06:15
Yes, sure :)
Go where the umbrellas are. You can collect 4 umbrellas on your way, then go to the top so that you see the arrow to the left. Go to the camel and touch the camels rein around his neck to tie it to a stone. Use your minidisc (music thingie) on him and then you can get the items you need :)

Blondiej1
01-29-2008, 01:09:38
thanks!!!

Lilliputt
01-29-2008, 01:14:55
You are welcome :)

Blondiej1
01-29-2008, 01:26:44
now what i see a camal the guy what do i use the other diamond for?

Lilliputt
01-29-2008, 01:37:05
Uhm... I dunno where you are Blondiej1. What do you mean "camal the guy"?

Yes... progress... I can go on now :D:D:D

Blondiej1
01-29-2008, 01:42:21
sorry i ment Camal, and the guy by the plane
but i have homework i didn't know i had so i will try again tomorrow GOOD LUCK TO YOU!!!!

Lilliputt
01-29-2008, 02:01:01
Thank you, dear. Good luck with the homework! :D See ya :hug2:

EDIT: I have added an important update on the first post of this game ;)

EDIT2: I made it to Peru :D Too tired to continue, though....

EDIT3: YAY! I finished!! :leb: Very funny game :D :D :D

kerrie365
04-08-2008, 13:11:22
ok..so i have got the 4 umbrellas and i put the mini disc thing on the camel and got items but i have no idea what to do next does anyone know what i have to do?!?!

minsol
04-08-2008, 14:53:35
strange game! but fun.
I have put dimond, stone and wather on the big sqere stone, how do i put fire on it? and whats the 5th thing?

leguing
04-08-2008, 16:41:59
how do I get the dimonds? Help!

nevermind. got them

the 5th thing you have to go back to the airport and get sticks. that is the 5th thing

barney
04-08-2008, 21:28:17
where are all the objects for the ability to get the plane and what are they?

after the camelwhat do you do?

are you able to write a walk through????

kaydow87
04-09-2008, 05:54:52
i have the sticks, the water, the rock, and the diamond on the platform...what goes in the upper spot? im stuck..

edit: nevermind... now stuck in the sphinx...

bethan123
04-09-2008, 23:16:51
i played dis game like in da summer .Gamershood mad slow

ME1212
04-10-2008, 03:52:33
I can't get past the first puzle!!!


:scared-couch::apl:ivn:

L0v3ly
04-12-2008, 03:49:29
ooh a new game is posted on the main page!?! well i'll be!! haha!

zmeace
04-13-2008, 06:12:24
this is off topic of the game but im just wondering what is going on with gamershood.com? did it shut down or something because there are no new games except for this one but this took a long time to come out

Phoenix_13
04-13-2008, 16:24:31
Can anyone tell me how I can get the plane?

What to do with the second Diamond?

What to do with the umbrellas?

How can I light the fire?

How did you get into the sphinx?


PLEASE HELP ME!(I'm completely stuck)

:yar::yar:

karinmi88
04-14-2008, 07:23:10
greek
While spinning, click the statue on self.
help

minsol
04-14-2008, 13:59:21
im also wondering how to litt the fire!?

(sorry for my bad english)

Googled and found this
Episode 2

EGYPT:

Valley view:
Click on view of valley and you will say 'understanding the papyrus'.
Click the papyrus on the view. Look at papyrus and note the 2 diamonds placement.

Click on red sled to go the Sphinx.

Sphinx view:
Take all 4 umbrellas.
Go down steps and get ancient stone at bottom left of stairs.
Talk to Professor and he will say that (she) your true love went to Peru couple days ago to work with Prof. John Search. He will need help to solve mystery of Sphinx.
Look close at the stand with hieroglyphs. Click on down arrow to look close at hieroglyph stand.
Place the ancient stone on bottom glyph (earth).
Note symbols on base TL-fire, BL- water, TR-earth, BR- wheat? 4 elements.

Camel:
Exit down, climb stairs and exit at top of umbrella stand.
Take chisel from bowl. Take 2 stones on sand. Comment about making fire.
Look at corner stone of pyramid - 2 diamonds carved on the stone.
Take the rope on camel's neck. Automatically rope tied to corner stone of pyramid.
Place mini disk on camel's head. Click on mini disk to turn it on. Camel pulls the stone away to reveal Papyrus and diamond.
Take papyrus and 2 diamonds. Go top of screen.

Airport:
Take paint and lubricant from under left wing of plane.
Take rope from crates just inside the hangar.
Take sticks from overturned barrel by hangar.
Talk to pilot.
Take hammer on ground by his left leg.
Go back to the umbrella stands by the Sphinx.
Exit to down arrow at top level of stairs.

Riverbank:
Take empty bottle on ground, sickle on right of screen and wheat from left of screen.
Use empty bottle on water to get bottle filled with water.
Use sickle on bamboo canes at right of screen. Exit.

Hieroglyph stand:
Look close at hieroglyph stand (down arrow).
Place wheat at top right.
Click bottle of water at bottom right to spill water on glyph.
Now for fire at top left. Place stick on glyph. Combine the 2 stones in inventory. Click the stones on stick on fire glyph to make fire.
Place a diamond at center.

Umbrella stand area:
In inventory, combine all 4 umbrellas together to make a sort of trampoline.
Click bamboos on combined umbrellas.
Click rope on trampoline setup to get a trampoline.
Place trampoline close to the red something on the ground.
Click on red something and you will jump on trampoline and land on Sphinx head.

Sphinx head:
Take stick.
At lower left look close at different colored stone on sphinx head.
Click chisel and then hammer on the odd colored stone to reveal battery slot.
Click torch-flashlight on your head to get 2 batteries.

Place one battery on slot.
Take chisel.
Go to top right of screen to get right pointing arrow. Exit here.
While hanging, place the other diamond on Sphinx' forehead.
Exit at bottom of screen. Go back to hieroglyph stand.

Sphinx door:
Pass on right aisle of hieroglyph stand and then go to top side of stand. Exit here.
Look at stone slab in front of sphinx. Click on your drawing in front of sphinx glyph (left of slab). The 2 diamonds shed light on each other to open door.
Enter opening.
Ugh! Take torchlight on wall. Go back out and light the torch on burning sticks on top of stand.
Go back in. Place torchlight back on the wall. Click at bottom arrow.

Arrow hallway:

While facing the shooting arrow hall, click the frying pan on yourself.

Dark room:

Raise the brightness of the monitor and see the dim layout inside the sphinx.
Move to the left edge of the platform and then click down arrow. The ledge goes down.

Wall:
Place the last battery on left middle panel to have light.
Place the stick on lever slot at bottom left.
Pull down the makeshift lever to show 9 panels of your adventures.
Click to rotate the panels in chronological order of your adventure:
Top 1: Bedroom with hanging plane, standing by elevator, getting package from Mr. George.
Middle: Facing the parrot, getting the dart pistol, Captain dancing,
Bottom: Catching train, getting statue at museum, sailing to Egypt.
The panels slides away. Take ancient object. Click the ancient object on museum statue.
Click on lever for it to go back up.
Take bow. Exit right.

Overview of the Valley:

The valley now has water. The pyramid you worked on is the one at the center.
Click on sphinx.

Sphinx view:

Talk to Professor. Give him the cell phone to call the pilot.
Then go back to the left arrow by the stairs.
Go back to Professor and get the cell phone. Exit left again.
Click at top left corner of screen.

Airplane:
Back at the plane with no pilot around.

Take gimlet on left tail end of plane and the sandwich on top of plane.
Give the sandwich to the camel and take the mini disc player.
Enter plane. Pull yellow throttle.
Click on Peru on the map.

minsol
04-15-2008, 18:21:07
and it didnt fitt all in one so here comesthe rest...


MEXICO

Runway:
Parrot arrives. Talk to parrot - note glyphs. You run out of gas in Mexico.
Click at bottom left arrow.

Road:
Take carpet hanging from window.

Bar Tequila:
Enter bar.
Talk to bartender.
Take tequila. Make a deal with the bartender.

Outside:
Go through beaded curtain.
Take pruning knife, pick and basket.

Look at barrel and see there's still tequila left. Click shot glass on barrel to get shotful of tequila.
Place the carpet on table. Use the paint on carpet - Party! The Alexk is here!
Take flyer carpet. Exit on bottom of screen.
Hang the flyer carpet on front of the bar.
Go back inside and talk to bartender. One more person to collect.
To get last customer - Go outside in front of bar. Combine lubricant with tequila.
Give the tequila-lubricant to sleeping guy.
Hit him with the frying pan while he's drinking the tequila.

He runs inside the bar.
Go back inside bar and talk to bartender.
Go back downstairs and take the funnel and barrel of tequila under the stairs.

Runway:

Go back to plane. Place funnel at middle of plane. Click barrel of tequila on it.
Click on plane and pull yellow lever. Click on Peru again.

PERU

Hanging Bridge:

Cross the bridge and the backpack falls off.
Take the pick from bridge and continue to other side.
Take rubber from rubber tree.
Go right to pyramid complex.

Pyramid Complex:
Enter the brown-green clear area.

Use pick on ground to make a straight line hole in the ground.
Add rubber on hole. Take rubber-rope.
Go back to broken hanging bridge.

Hanging Bridge:

Look down using down arrow.

With view looking up on bridge, click rubber rope-bungee on bridge.
Click on backpack until you're able to take it. Click on top of the Lacta icon to get the strap of the backpack.
Go back to pyramid complex.

Pyramid complex:
Climb the stairs to top of pyramid. Door is locked. Stand by the second from right window.
Take bow and arrow from inventory and the monkey with the key reappears.
Click on monkey and you will first shoot down a banana, a small Lacta, a large Lacta, bat and finally the key.
Pick up the key from the left totem's base. Climb back up the pyramid.
Use key on door at top of pyramid. Enter.

Inside locked door.
See glyphs on floor. Call parrot using whistle.
Talk to parrot. Remember the sequence of the glyphs.
Click the glyphs in the same sequence. You can ask parrot again to check.
The center part opens. Stand on center to go down inside the pyramid.

Inside pyramid:
On the walls are rings used in the ancient Mayan ballgame.
Place the ball on the round depression behind the totem.
Click ball. The ball bounces on the wall rings. The totem mouth opens. The mouth is too high.
In inventory, click the clipper on basket to get a rope.
Click rope on totem. Then click rope again. Pick an object like the one in Egypt.
Combine the object like the one in Egypt with the statue + the one from Egypt to make a statue.
Press the heart glyph on totem's waist. Door opens.
Exit. Go back to plane.

GREECE

Plane:

Click on Greece on map. Pull throttle.
Take axe, cloth and wire from plane. Uh Oh!
Use axe on barrel. Take planks and click planks on yourself.

Click wire on yourself to tie the planks to your leg.
Click cloth on yourself. Click on up arrow to jump out of plane.
Nice skiing down the mountain.


Oracle temple area:

Look at block with something written on it. Click on right arrow.


Cliff:

Look at diamond glyphs on wall of ruins. Use pick on glyphs.
Take 2 diamonds.

Go left of screen (close to left arrow). Look under the bush and take soil.
Go left arrow.


Stone circle:

Look at circular stone structure. It has 2 holes in the ground.
Take stone on ground by top wall.
Go to top left exit.

Oracle temple area:

Back on the inscribed stone. Place soil on inscribed stone.
Place blank papyrus on it (click the fine papyrus on self).
Use stone on papyrus. Take papyrus. Read it. Go left.

Stone circle:

Walk to the 2 holes inside the stone circle. Place the diamonds on the hole.
Stand on top of circular stand at center. While spinning, click the statue on self.

OUTER SPACE-Moon

Metallic geodesic room:

Click on square column and whoa. Outer space time!
Back at the metallic geodesic room, go to the right wall.
Click remote control on right wall. Click to cycle the numbers to form 18A09B70A.
A space suit appears on center wall. Take space suit.
Wearing suit, go through the opened stairs at right.


Chasm:
Click remote control on door across the chasm to get an arrow to it. (trigger to cross chasm).
Go to top of screen and hop along the chasm. Enter door.

Inside:
Go to center of the circle on the floor.
See a hologram of the planets. Look at Earth.
Click on moon to change it to heart, square, diamond, moon again.
Click on Earth when the screen shows only the large moon and large earth. You'll jump back to earth.

Big Ben:
Go to opposite end of walkway to the trapdoor.
Use gimlet on trapdoor.

Gear Room:
Note some of the gears are not working fine.

Use chisel and then hammer on small top gear. Exit left.

London Bridge: Exit down.

Red & White Club:
Talk to bouncer.
Give the other half of Lacta wrapper.
Talk to him until he removes the rope.
Enter.

Inside Club:
Go to your true love at bottom of screen. Talk to him.



im stuck on the moon!! i cant go to earth as the walkthru says

lil'bitmo23
04-18-2008, 01:12:04
...Zwingo....True Love.....***. Where the heck r all the really good games..gamershood is slackin'

marooc
04-23-2008, 14:26:44
i'm about to loose it. i'm stuck at this stupid place between the thomb and umbrellas and can't move my character at all... no matter how much i refresh the page the game won't re load what is this?

MousePrincess
04-26-2008, 14:50:16
i'm about to loose it. i'm stuck at this stupid place between the thomb and umbrellas and can't move my character at all... no matter how much i refresh the page the game won't re load what is this?

If you have trouble moving your character, click your cell phone at the bottom right and look for an icon that says "Reset character position." Click that, and you should be free. It won't destroy any progress, just gets your character unstuck :)