PDA

View Full Version : Soul Sister



Mistery
02-02-2008, 02:30:07
This is a playable demo of a point-and-click game.
Night after night I've had this dream... I see a girl in the attic window of this old asylum. She scream out in fear, a scream that wake me up. It seem as my only hope to get rid of this nightmare and hopefully help the girl in need, is to confront it. Night fall as I open the rusty gate to the abandoned building that is holding more memories of screams, despair and lunacy than any man or woman can handle. What has happened here?
Note: This is a playable demo release, taking you about half way through the game.
The demo ends when the scary part is about to begin and the tragedy behind the story is about to be revealed... It was initially created in 2003-2004 and was recently (december 2007) completed to this playable state. Time will tell if it ever will be completed.

Due to mild violence, this game is not suitable for children!


Play Here (http://www.newgrounds.com/portal/view/422819)


Please use spoilers to give hints:
Enter text here...

ShiningStar
02-02-2008, 03:42:32
very short but it was a good demo :)

HANFGARN
02-02-2008, 12:26:26
I'm stuck in the shed, trying to get the hammer thing to work :S

Jeral
02-03-2008, 02:34:42
I'm stuck in the shed, trying to get the hammer thing to work :S

Go out of shed, then use hammer on the boarded window to the right of the door(of the mansion).

old biker
02-03-2008, 10:42:26
dont seem to be able to start the game in IE:?
or do i have to sign in first ?

scambo
02-05-2008, 03:20:11
yeah, i can get into the house but that's about all. I picked up the bucket but don't know what to do with it.

I also found the hose but couldn't disconnect it.

I'm stuck

ShiningStar
02-05-2008, 03:24:17
yeah, i can get into the house but that's about all. I picked up the bucket but don't know what to do with it.

I also found the hose but couldn't disconnect it.

I'm stuck

if I remember right I think you had to cut the hose



I'm stuck in the shed, trying to get the hammer thing to work

to get things you need to drag and drop them on you

scambo
02-05-2008, 03:34:35
ummmm.... shiningstar... i can't find anything to cut it with... got any clues for me? lol ;)

ShiningStar
02-05-2008, 03:42:43
you need to find a knife, but I can't remember where I found it might have been in the kitchen or the rooms:?

scambo
02-05-2008, 03:47:49
Yay..... i found it... actually it was scissors!

Ok... maybe I should just quit this game. I am hopeless. now i'm stuck again..... will keep digging around

ShiningStar
02-05-2008, 04:18:30
what are you stuck on :?

scambo
02-05-2008, 04:23:43
Ok... I'm stuck after I got the hose. Now I really dont know what it's for? I thought maybe the well but dont know why and can't get it to work anyway.

ShiningStar
02-05-2008, 04:25:21
you use it in the bathroom, you need to move the last drain, and put the hose down it

scambo
02-05-2008, 04:35:51
I can't get it!!! How frustrating... i'm looking at it and she's saying there's something down there but when i drag the hose over the hole... it says nothing happens

ShiningStar
02-05-2008, 04:40:47
you need to drag the top of the drain to her and then you can use it

scambo
02-05-2008, 04:45:20
yep, did that, and now i have a close up of her and the drain...... 'can't reach it' she says but then i drag the hose to the hole and nothing happens.. I think i'll have to leave it it's giving me a headache..... lol

ShiningStar
02-05-2008, 04:46:06
hmm ok let me replay it and see what it was :)


ok connect the hose and the bucket, go outside to the well and use the bucket, go back to the drain and use it there :)

scambo
02-05-2008, 04:49:43
Oh shiningstar... thank you. I've managed to connect the hose to the bucket but still can't put it down the hole!!

I'm sure you'll put me on the right path..... lol

ShiningStar
02-05-2008, 04:52:40
you need to fill it with something first ;)

scambo
02-05-2008, 05:05:37
Oh yay!!! finally!!! thank you, thank you shiningstar!!!! i think I should go back to work now as my brain is not up to this today! mwa!!

ShiningStar
02-05-2008, 05:10:53
anytime ;)

Moosh
04-23-2008, 14:23:22
Help I can't get her to "take" the drain cap.

Niniricci
04-23-2008, 16:19:18
Nice demo... looks like it would make a great full-game!

lxagunos101
04-23-2008, 23:34:38
Where is the bucket? That's all that I'm missing.

EDIT!: Nevermind. Pixel hunting. Lol

Spearbunny
04-24-2008, 02:08:09
where do you find the scissors?

NannaJoy
04-24-2008, 21:43:56
Not bad - although the dark screen makes it difficult to see.

starkrazi
04-27-2008, 19:51:58
ne help please i found key opened room but don't know what else to do

miss_steak
05-01-2008, 16:05:01
how do i pick stuff up? i can move the hammer but dont know how to put it in my inventory!

found out, NVM

JustinCord
05-20-2008, 19:31:07
WTH!? When I went to the bathroom I saw the hose. I tried to pick it up but it said I cant unscrew it. Then I tried picking it up a couple of more times and it kept sayong the same thing. So I tried turning on one of the showers. And then when I finished trying to turn on the last shower I saw a flash of a girl with medium hair and she had a long robe on and her right sleeve was pointing down since is was big. Who or what was the flash?

You have to put items you can move on you then it will be in your inventory.

magsta
05-22-2008, 04:05:46
where r the scissors

nm i found it