+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Can't play!!

  1. #1

    Default Can't play!!

    Someone can explain me why I can't play any game on gamershood???
    Help me, please!!

  2. #2
    Veteran Mistery's Avatar
    Join Date
    Dec 2005
    Watching from above


    What do you mean exactly? Can't you play games that are hosted on www.gamershood.com or can't you play any flash games in general?

    Make sure that you have the latest Flash Player version installed.
    Go to this page:
    and it should display which version of Flash Player you have installed.
    If it's not version then upgrade it.

  3. #3
    Mod on Call Adventure's Avatar
    Join Date
    May 2006
    The Netherlands


    Hi Biscuit,

    Please post at least one link to a game you are experiencing this issue with, and we will look into it.
    In advance, thanks you very much for reporting it. Our administrator has been notified about it.
    Faily of Kzin

  4. #4
    Administrator GamersHood's Avatar
    Join Date
    May 2005
    on the edge


    Hi Biscuit,

    I had the similar problem. All the Mochi games were working, but then, out of the blue, all the Mochi games were unloaded(blank screen). This happened on every site i checked. I didn't find any help, but i did a weird thing what seemed to help. I refreshed one game several times, every time Mochi loaded a little longer and longer, after few refreshes the game was working and after that every other game were working too. Try to refresh one Mochi game several times, i hope this will do the trick.

    He who fights and runs away can run away another day.

  5. #5
    Super Biker Mod old biker's Avatar
    Join Date
    Jan 2007
    belgium antwerp


    had the same issue about mochi

  6. #6
    Advanced User
    Join Date
    Jul 2012
    Los Angeles, USA


    All Games Menu content links are broken on front end. The white space that would be populated with large thumbnails is just white space with one active ad tile in lower right-hand corner. The phrase "Nothing found" appears in the bottom of the white space. Mouse-over ads can be invoked and closed. Some ad invocations are set to fire when links from Games Menu are clicked. The ads play, but there is no transfer to content sub-menu. Grammar parsing of search argument occurs, but search fails with "Nothing found" message.

    Was able to play on GamersHood.com yesterday. Can play on other sites such as GotMail.com, Yizzim.com and HoodaMath.com. Can play through other portals such as Nordinho.net and EscapeGameHint.blog.fc2.com. Updated to latest flash player this morning, but no joy at GamersHood.

  7. #7
    Junior User
    Join Date
    Feb 2006


    Having the same problems as Pamster00. It's been going on for 2 days now. I have no idea how to fix/what to do. Any help would be appreciated. I haven't tried getting in any other way than gamershood.com. Thanks - JJay

  8. #8

    Default Can't play either

    Unfortunately I'm having the same issue. The links worked fine for me a couple days ago, but now I just get the error "Nothing Found" When I click any of the menu links up to and including "Gamershood top 15"... nothing. Hope this gets fixed soon!!!

  9. #9

  10. #10


    Same here

+ Reply to Thread

Similar Threads

  1. Play School Escape
    By GamersHood in forum Escape The Room Games
    Replies: 22
    Last Post: 01-30-2010, 03:15:47
  2. Click Play (Clickplay)
    By wolf in forum Arcade/Action
    Replies: 8
    Last Post: 06-05-2009, 19:24:35
  3. Wogger-Mini Episode 43 to 92
    By Adventure in forum Point and Click Adventure Games
    Replies: 306
    Last Post: 12-14-2007, 22:16:09
  4. Wogger X-Mas (Episodes 1-42)
    By Adventure in forum Point and Click Adventure Games
    Replies: 273
    Last Post: 05-15-2007, 16:52:56

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts